EAS build error - Unable to add a source with url `https://cdn.cocoapods.org/` named `trunk`


Using managed workflow with eas-cli version 0.52.0

Currently when running an internal development eas build for ios I am getting a build error.

The command I am running:

eas build -p ios --profile development

The logs are below:

Adding spec repo `trunk` with CDN `https://cdn.cocoapods.org/`
[!] Unable to add a source with url `https://cdn.cocoapods.org/` named `trunk`.
You can try adding it manually in `/Users/expo/.cocoapods/repos` or via `pod repo add`.
[stderr] [!] `<PBXResourcesBuildPhase UUID=`13B07F8E1A680F5B00A75B9A`>` attempted to initialize an object with an unknown UUID. `B6F045FF8EBF485DBD16859D` for attribute: `files`. This can be the result of a merge and the unknown UUID is being discarded.
pod exited with non-zero code: 1

I have tried searching for information around this issue, and some indicators are that there may be issues with the cocoapods CDN, however when checking the status page, all things show operational:

I have also tried with a previous version of eas-cli, and removing any of the newer modules used so that the build is the same as my previous successful build, which makes me think it is an issue with the eas build itself.

It looks like it’s the issue with cocapods, it affects all ios build

Ah yep that looks like the one, nice one, thanks! Apologies, I didn’t see that issue, I’ll check the cocoapods repo issues in future

you can find workaround for managed projects here Install pods fails with: Unable to add a source · Issue #1099 · expo/eas-cli · GitHub

1 Like

Yesterday we had upgraded to Expo EAS production plan. So at first, we thought something related to our plan upgrade did not go well, and that is causing cocoapods to not install, and so our builds are failing. Glad to see that that is not the case :slight_smile: The solution shared above worked :smiley: Instead of 1minute it took 11minutes for the Install Pods step to complete.

Yep agreed! This is working for me also

@sumeetpareekt21 We updated that example, if you use new version pod install time should be normal

1 Like

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.