EAS Build:configure... git command not found

Hello friends!

I’m having some issues with EAS Build and Configure. If I run ‘eas build [ios,android, or all]’ I get the following message:

Your iOS project is not configured to build with EAS. Set it up now? » (Y/n)

I then hit ‘y’ and get the following message:

Error: git command not found, install it before proceeding

What git command? How can I install it? I haven’t found any other people with this issue, so any information would be greatly appreciated.

Here is a screenshot of the issue (I think, I’m not 100% sure I did it right)
eas build issue

And here are the results of ‘expo diagnostics’

PS C:\Users\Jon\Downloads\QANC-App-develop> expo diagnostics

Expo CLI 4.7.3 environment info:
OS: Windows 10 10.0.19043
Node: 12.19.0 - C:\Program Files\nodejs\node.EXE
Yarn: 1.22.10 - C:\Users\Jon\AppData\Roaming\npm\yarn.CMD
npm: 6.14.8 - C:\Program Files\nodejs\npm.CMD
Android Studio: Version AI-201.8743.12.41.7042882
expo: ^40.0.1 => 40.0.1
react: 16.13.1 => 16.13.1
react-dom: 16.13.1 => 16.13.1
react-native: https://github.com/expo/react-native/archive/sdk-40.0.1.tar.gz => 0.63.2
react-native-web: ^0.17.1 => 0.17.1
Expo Workflow: managed

PS C:\Users\Jon\Downloads\QANC-App-develop>

Please let me know if you need any additional information. Thanks!

Hi @jpryzby

Git is software for keeping track of the history of your project as you develop it.

It can be downloaded from here:

See the documentation link on that site for how to use it.

Oh I understand, I did not realize Git was a prerequisite for EAS. It has been installed and my problem is now fixed. Thanks for the help!

1 Like

you can also disable git if you want by setting EAS_NO_VCS=1 on each command or in your shell profile. that said, you need to have either a .gitignore or .easignore file in your project directory in order for eas-cli to know which files to skip uploading to eas build (eg: you don’t want to upload your node_modules directory or any temporary build files, most likely)

1 Like

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.