Eas build - cant fetch profiles


Every time I execute eas build --profile preview --platform ios
I get this error:

× Failed to fetch Apple provisioning profiles
Failed to setup credentials.
    UnexpectedAppleResponse: The specified resource does not exist - There is no resource of type 'profiles' with id 'CWWAZ53HCG'

But when I run eas build --platform ios everything goes smoothly and I end up with successful build on eas cloud

my preview profile:

      "preview": {
        "distribution": "internal",
        "workflow": "managed",
        "credentialsSource": "remote"
      OS: Windows 10 10.0.18363
      Node: 14.15.1 - C:\Program Files\nodejs\node.EXE
      Yarn: 1.22.4 - C:\Program Files (x86)\Yarn\bin\yarn.CMD
      npm: 6.14.8 - C:\Program Files\nodejs\npm.CMD
      expo: ~40.0.0 => 40.0.0
      react: 16.13.1 => 16.13.1
      react-dom: 16.13.1 => 16.13.1
      react-native: https://github.com/expo/react-native/archive/sdk-40.0.1.tar.gz => 0.63.2
      react-native-web: ~0.13.12 => 0.13.18
    Expo Workflow: managed

did you possibly delete credentials manually from the apple developer account? (this place: https://developer.apple.com/account/resources/certificates/list)

Nope, cli successfully checks for certificate and finds it. Problem occurs only when it comes to provisioning profiles. When I build for “release” everything is okay (App Store profile is created) but when I try internal testing (ad hoc profile) cli fails

ad-hoc profiles are also stored on apple developer. for example, here’s an ad-hoc profile created for internal distribution with eas build.

notice the id in the url bar. you should be able to find a provisioning profile corresponding to your app with the id that you got in the error message.

i suspect it is not there, perhaps it was manually deleted.

so you can go to your project page on expo.io, then in the sidebar choose “Credentials”, then go to “Ad hoc client” and remove the provisioning profile

1 Like

Somehow old profile was oddly cached in my project and i could not get rid of it, I had no provisioning profiles associated to my project, so removing or reinstalling profiles/certificate did not help at all.

However I did manage to fix it by reinitializing the project from scratch. Nevertheless thank you for the valuable info about profile ids in Apple Dev, now I know where to look at)

could you possibly share the username and app slug for the app where you were having this issue? it’d be helpful for us to be able to investigate the root cause

I’ve got the same issue occurring on @blacklotusinc/HabitPlayer in case that can help debug.

thanks! is this also for internal distribution for you?

It is, yes.

For anyone still needing help with this I seem to have fixed it by using eas credentials and then using the option Remove Distribution Certificate and Remove Provisioning Profile from current project to remove the distribution certificate and remove the provisioning profile. Then I used the Ensure all credentials for project are valid to regenerate everything and it seems to have worked.

hi there!

if you run into this, can you please run eas build with the EXPO_APP_STORE_DEBUG=true set?

eg, if you use macos/linux: EXPO_APP_STORE_DEBUG=true eas build

once you do this, please paste the log output here

@tomkallen @zencephalon i’m trying to repro your problem with a similar profile but i’m having some trouble :frowning:

Can you let us know:

  1. What version of eas-cli do you have? run: eas --version
  2. ur log output when u run eas build with the EXPO_APP_STORE_DEBUG=true env var?

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.