eas build android failing

Unable to do eas build -p android when there is an app.config.js file present.

  • Using managed workflow
  • eas-cli/0.55.1 darwin-x64 node-v14.19.0
  • What has been tried?

import { AppRegistry } from “react-native”;
import App from “./App”;
import { name as appName } from “./app.json”;
AppRegistry.registerComponent(appName, () => App);

What’s been determined is that eas build -p android works if there is no app.config.js present, but fails if there is one present.

Using the bare bones app.config.js like below fails.

export default ({ config }) => {
console.log(config.name); // prints ‘My App’
return {
…config,
};
};

Error message is below:

Blockquote
[RUN_GRADLEW] expo-45-app
[RUN_GRADLEW] warning: the transform cache was reset.
[RUN_GRADLEW] Error: The resource /private/var/folders/7t/b1nmcbn95bg33vkxfk2km3v00000gn/T/eas-build-local-nodejs/2300ad0d-73d6-421a-bacc-7bdd6f0a2892/build/expo-45-app [RUN_GRADLEW] index.js was not found.
[RUN_GRADLEW] at /private/var/folders/7t/b1nmcbn95bg33vkxfk2km3v00000gn/T/eas-build-local-nodejs/2300ad0d-73d6-421a-bacc-

A colleague solved this mystery. Having logging statements in your app.config.js breaks android eas building in expo 45.