EAS build always outputs old versions to testflight

I’ve been having a very strange problem.

Every time I build our app using eas build --platform ios and submit the app to testflight using eas submit, the app that gets submitted is an old version from about 3 months ago.

Incrementing the version number works, and on my phone I’ll get a testflight update, but after updating (even after I delete the app itself) it always results in downloading the old version from 3 months ago (with a new version number!).

This only happens when submitting production builds to testflight. When I do ad hoc builds it results in the correct (new) version of the app being on my device. Also, ejecting to react native and building + uploading the app with xcode results in the correct (new) version being sent to testflight.

We have tested this out using two separate Apple developer accounts using eas build on two separate expo accounts and had the same problem of the old version of the app being uploaded to testflight. Since this works normally after ejecting, I believe that this is a eas build problem

share a link to your build and submission pages and we can investigate. for what it’s worth, there isn’t anything eas build is doing differently that would cause this so there is likely some misunderstanding or misconfiguration occurring.