EAS - Android resource compilation failed

Hi there.

I am trying my first EAS Build and got the following error:

I’ve tried this solution:

But the error continues. Any thoughts?

I can build with expo build, but not with EAS.
I don’t have the “assets_images_home.png” file in my project folder.

My app.json:

"expo": {
    "name": "Psiquê",
    "slug": "psique",
    "privacy": "unlisted",
    "platforms": [
    "version": "0.9.19",
    "orientation": "portrait",
    "icon": "./assets/images/IOS/psique_icone.png",
    "splash": {
      "image": "./assets/images/Splash_Hasti.png",
      "resizeMode": "cover",
      "backgroundColor": "#EEEEEE"
    "updates": {
      "fallbackToCacheTimeout": 0
    "assetBundlePatterns": [
    "packagerOpts": { 
      "config": "metro.config.js", "sourceExts": ["js", "jsx", "svg", "svgx"] 
    "ios": {
      "bundleIdentifier": "com.t2p2.psiqueapp",
      "buildNumber": "0.9.19",
      "supportsTablet": true,
      "infoPlist": {
        "NSCalendarsUsageDescription": "Permitir ao usuário agendar consultas",
        "NSCameraUsageDescription": "Permitir tirar uma foto para usar no perfil",
        "NSContactsUsageDescription": "Permitir adicionar o contato do psicólogo",
        "NSLocationWhenInUseUsageDescription": "Permitir que o Psiquê registre o local de registro",
        "NSMicrophoneUsageDescription": "Permitir o registro por voz no diário para seu psicólogo",
        "NSMotionUsageDescription": "Permitir que o Psiquê detecte movimentos",
        "NSPhotoLibraryAddUsageDescription": "Permitir que o Psiquê grave fotos no seu dispositivo",
        "NSPhotoLibraryUsageDescription": "Permitir que o Psiquê acesse suas fotos para o perfil",
        "NSRemindersUsageDescription": "Permitir que o Psiquê adicione lembretes para você"
    "android": {
      "package": "com.t2p2.psiqueapp",
      "versionCode": 42,
      "permissions": []

Hmm now I understand. :sweat_smile:

The file name is not “assets_images_home.png”. This is a combination of the folder and file name. I removed the home.png file and the build worked.

1 Like

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.