eas android build failed with error - "Cannot find module "'./resolvePackageJson'"

Expo Logs shows -

Build failed Cannot find module ‘./resolvePackageJson’
Require stack:

  • /build/node_modules/@expo/build-tools/node_modules/@expo/config/build/Config.js
  • /build/node_modules/@expo/build-tools/node_modules/@expo/config/build/index.js
  • /build/node_modules/@expo/build-tools/dist/context.js
  • /build/node_modules/@expo/build-tools/dist/index.js
  • /build/dist/ios/build.js
  • /build/dist/build.js
  • /build/dist/service.js
  • /build/dist/ws.js
  • /build/dist/main.js

When I check my node_modules, I am able to find the “resolvePackageJson” module

"node_modules\expo-cli\node_modules@expo\config\build\resolvePackageJson.js"

But the build happens on expo site and there the process is not able to find this module

can you share a link to the failing build page please?

This is the link

do you have expo-cli installed in your package.json? if so, please remove it. it is meant to be installed globally.

actually that may not even be the issue.

it looks like your package.json does not exist in the root of your project:

is this a monorepo? if so, you need to follow instructions for how to run builds for monorepos. Integrating with third-party tooling - Expo Documentation

package.json is in the root directory and I’m running the command as follows

“eas build -p=android --clear-cache”

The message on the expo site says

Failed to parse or read package.json: package.json does not exist in /build/workingdir/build

what is this folder /build/workingdir/build?

I also removed the lines in package.json related to expo* modules…still get the same error that it cannot find module - “resolvePackageJson”

your project is in some way malformed. please share more information about it and any relevant files

Thanks…I updated the eas version to the latest and it seemed to fix the problem

Also, I built using expo instead of eas
expo does not allow submission and eas throws an error for build

So, I built using “expo”
and submitted to app store using “eas”

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.