Does expo works on Catalina ?

MY system keeps on freezing up when i run yarn start --ios

± expo diagnostics

Expo CLI 3.27.14 environment info:
OS: macOS 10.15.6
Shell: 5.7.1 - /bin/zsh
Node: 10.15.3 - /usr/local/bin/node
Yarn: 1.3.2 - /usr/local/bin/yarn
npm: 6.14.6 - /usr/local/bin/npm
Watchman: 4.9.0 - /usr/local/bin/watchman
Platforms: iOS 14.0, DriverKit 19.0, macOS 10.15, tvOS 14.0, watchOS 7.0
Xcode: 12.0.1/12A7300 - /usr/bin/xcodebuild
expo: ~39.0.2 => 39.0.3
react: 16.13.1 => 16.13.1
react-dom: 16.13.1 => 16.13.1
react-native: => 0.63.2
react-native-web: ~0.13.12 => 0.13.18
expo-cli: 3.27.14
Expo Workflow: managed

yes it does. not sure what might be wrong with your setup, we’d need more information and you might want to try standard troubleshooting techniques to dig deeper

What info do you need @notbrent ?

it looks like xcrun is failing. try starting with just yarn start and then press i to open simulator to see more info. also try starting simulator separately. something is wrong with simulator startup on your machine

I tried, Same fucking Bullshit.

Opening on iOS…
(node:89756) UnhandledPromiseRejectionWarning: Error: xcrun exited with non-zero code: 4
at ChildProcess.completionListener (/usr/local/lib/node_modules/expo-cli/node_modules/@expo/spawn-async/src/spawnAsync.ts:65:13)
at Object.onceWrapper (events.js:277:13)
at ChildProcess.emit (events.js:189:13)
at maybeClose (internal/child_process.js:970:16)
at Process.ChildProcess._handle.onexit (internal/child_process.js:259:5)

at spawnAsync (/usr/local/lib/node_modules/expo-cli/node_modules/@expo/spawn-async/src/spawnAsync.ts:26:19)
at xcrunAsync (/@expo/xdl@58.0.13/src/SimControl.ts:323:18)
at Object.bootAsync (/@expo/xdl@58.0.13/src/SimControl.ts:137:11)
at action (/@expo/xdl@58.0.13/src/Simulator.ts:310:25)
at waitForActionAsync (/@expo/xdl@58.0.13/src/Simulator.ts:292:22)
(node:89756) UnhandledPromiseRejectionWarning: Unhandled promise rejection. This error originated either by throwing inside of an async function without a catch block, or by rejecting a promise which was not handled with .catch(). (rejection id: 29)
(node:89756) [DEP0018] DeprecationWarning: Unhandled promise rejections are deprecated. In the future, promise rejections that are not handled will terminate the Node.js process with a non-zero exit code.

it’s hard to say what is going wrong. xcrun is an xcode utility for interacting with simulators, and it’s the only reasonable api for us to use here. it doesn’t provide any documentation around the exit codes, as far as i know, so exit code 4 isn’t so meaningful to us. you can open the simulator manually by looking for “simulator” in spotlight, download the expo client app from (the “Download IPA” link), extract the downloaded archive to get the .app file, and then drag and drop the .app file into the simulator to install the expo client app. if you end up learning more about what exit code 4 means, let us know.

I hesitate to suggest this because of how large it is, but maybe try reinstalling Xcode?

I couldn’t find any .app file after i extracted the downloaded archive.

ah sorry, the folder is the .app. you can rename the entire extracted folder to add the .app extension then drag that in

1 Like

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.