Disable the shake trigger?


Is there a way to disable the shake trigger that opens the developer (debug) menu? We’d like to use the shake event in our app and, while testing it, the developer menu always shows up.


On the home screen of the Expo client, go to your profile, go into settings, and there’s an option to change from the shake to a two-finger long press (force touch on iOS devices that support it). This conflicts with pinch gestures but will “free up” the shake gesture.

1 Like

It worked! Thank you!

With version 2.11.2 there’s no settings under profile. Does it still possible to disable the shake action ?

1 Like

I’m using client app version 2.15.2 in ios and there is no longer an option to disable shake (Enable two finger long press) :frowning:


Yeah. What’s the deal. Shaking is annoying

I also used the two finger long press on iOS. When I found out about the removal of this option I was disappointed, but there is a workaround that I’ve been using:

You can enable AssistiveTouch and then map some action like double tapping to a shake. In case you’re not familiar with AssistiveTouch, as I wasn’t, it brings up a translucent button near the bottom right of your device that you can tap to cause it to do whatever is defined for that action in the settings.


thanks. this helps! i configured it to shake on long press.