disable idfa in expo-firebase-analytics

Please provide the following:

  1. SDK Version: 42.0.3
  2. Platforms(Android/iOS/web/all): iOS

My Kids Category app is getting rejected from the app store with the below message (accessing IDFA). I do want / need app analytics, but can’t find any way to disable IDFA access in the expo-firebase-analytic documentation. Is there a way to do it, if not, is it planned, and if not, is there a way to get my app approved without disabling it? Or do I have to remove expo-firebase-analytics entirely?

Rejection message:

Guideline 1.3 - Safety - Kids Category

We noticed that your Kids Category app includes analytics, advertising and collects, transmits, or has the ability to share personal information or device information with third parties. Specifically:

  • Your app includes third-party analytics or third-party advertising with the ability to collect, transmit or share identifiable information, including, for example, IDFA. We found that your app references the ASIdentifierManager API, which provides access to a user’s IDFA, in the following location(s) in your binary:

• /System/Library/Frameworks/AdSupport.framework/AdSupport

It would be appropriate to remove all instances of “ASIdentifierManager” from your app, even if they are not utilized in your app’s functionality.

Next Steps

To resolve this issue, please remove this functionality or revise your app so that no personally identifiable information or device information is sent to third parties.


Learn more about our policies for Kids Category apps in App Store Review Guideline 1.3.

Hi there, me again. After reading up some more, I realized that no third party analytics whatsoever are allowed in the kids category. I ended up removing expo-firebase-analytics and ejecting. Got approved when I resubmitted.

1 Like

Hi @jonasfrid

These days there’s also another option.

See Brent’s answer to another question about a kids’ app.

1 Like

Sounds great, I’ll be monitoring the status/success of eas kids apps then. I’d love to be able to “inject” again :slight_smile:

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.