Deep Linking doesn't work - is this config right?

Hi guys,

I’m trying to use DEEP LINKING with Android but don’t get it working.

This is my domain: https://mystartup.app/

I want to link the homepage and all sub sites to my android app.

My app.json looks like this:
“android”: {
“useNextNotificationsApi”: true,
“package”: “com.mystartup.mystartupapp”,
“googleServicesFile”: “./google-services.json”,
“adaptiveIcon”: {
“foregroundImage”: “./assets/adaptive-icon.png”,
“backgroundColor”: “#ffffff”,
“backgroundImage”: “./assets/adaptive-icon-bg.png”
},
“intentFilters”: [
{
“action”: “VIEW”,
“data”: [
{
“scheme”: “https”,
“host”: “mystartup.app”,
“pathPrefix”: “/.*”
}
],
“category”: [
“BROWSABLE”,
“DEFAULT”
]
}
]
}

Unfortunately this doesn’t work - when I visit https:// mystartup.app/ or https:// mystartup.app/contact via the mobile browser, the app won’t open or ask to open

1.) Does my config look right to you?
2.) Do I need to install the APK to test this or should this also work in Expo Go ?

Hey @danielkolbespecial, you’ll need to build an apk to have the custom deep link config to take effect. Have you done so and it still isn’t working?

Cheers,
Adam

{
“expo”: {
“name”: “Myapp”,
“slug”: “Myapp-mobile”,
“scheme”: “myapp”,
“version”: “1.5”,
“orientation”: “portrait”,
“icon”: “./assets/cj_favicon_2.png”,
“splash”: {
“image”: “./assets/splash.png”,
“resizeMode”: “contain”,
“backgroundColor”: “#ffffff
},
“updates”: {
“fallbackToCacheTimeout”: 0
},
“assetBundlePatterns”: [
“**/"
],
“android”: {
“package”: “io.myapp.app”,
“versionCode”: 30,
“useNextNotificationsApi”: true,
“icon”: “./assets/cj_favicon_2.png”,
“googleServicesFile”: “./google-services.json”,
“permissions”: [“WRITE_EXTERNAL_STORAGE”, “READ_CONTACTS”],
“intentFilters”: [
{
“action”: “VIEW”,
“autoVerify”: true,
“data”: [
{
“scheme”: “https”,
“host”: “app.myapp.io”,
“pathPrefix”: "/verifyemailscreen?param=

}
],
“category”: [
“BROWSABLE”,
“DEFAULT”
]
}
]
},
“ios”: {
“googleServicesFile”: “./src/Helper/GoogleServiceInfo.plist”,
“bundleIdentifier”: “io.myapp.app”,
“supportsTablet”: true,
“buildNumber”: “3”,
“infoPlist”: {
“LSApplicationQueriesSchemes”: [
“itms-apps”
]
},
“associatedDomains”: [“applinks:app.myapp.io”]
},
“notification”: {
“icon”: “./assets/notifications/cj_notification_icon.png”,
“color”: “#000000”,
“iosDisplayInForeground”: true,
“androidMode”: “collapse”,
“androidCollapsedTitle”: “Myapp”
},
“web”: {
“favicon”: “./assets/cj_favicon_2.png”
},
“extra”: {
}
}
}

I have issue that after making build it is not opening the link in browser and also not gives any option to open app.
This is my app.json file’s content. is here everything is okay?

Please answer this :-
Do i need to create .well-known file in app root directory with assetlinks.json file and apple-app-site-association file.

if yes then i have created and added content check if it is correct

apple-app-site-association file:-
“applinks”: {
“apps”: ,
“details”: [{
“appID”: “564PAJTRK.io.myapp.app”,
“paths”: ["/verifyemailscreen?param=*"]
}]
}

assetlinks.json:-
[{
“relation”: [“delegate_permission/common.handle_all_urls”],
“target”: {
“namespace”: “myapp”,
“package_name”: “io.myapp.app”,
“sha256_cert_fingerprints”:
[“71:02:CD:E5:77:C2:C5:5B:59:5B:D8:A5:A1:9A:66:A8:A4:F2:AF:D7:VC:FA:43:9C:45:4E:29:1F:70:03:80:A0”]
}
}]

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.