Debug release stopped taking changes

Hi, today suddenly the debug release built using react-native-scripts android completely stopped to takes changes (on real android device). A component still throw the error below, even if I repeatedly re-build and now the component looks like this

export default class Settings extends Component {
	render() {
			return (<Text>wut is happening?</Text>)

Please note: I’m not talking about Live Reload or Hot Reloading, I’m talking about a new debug release, basically I cannot work right now.

well…it’s pretty urgent.
Currently sometimes the build takes correctly the changes, but most of the times it doesn’t.

Hi @alfredopacino - I’m not sure how to help without a way to reproduce this issue. Have you tried restarting your packager and clearing the cache (exp start -c)?

I undestand it cannot be reproduced, I’m writing here hoping this is a known issue or at least there are some common causes for this. Basically I cannot keep working on my app currently. I will try with that command, thanks.

There is a way I can reinstall the file watcher?

Here my env, maybe it could help

Windows x64
npm 5.6.0
node 8.9.4
exp 54.0.0

I usually run my app using yarn run android (react-native-scripts android).
I tried your command and launched the app in development mode, it takes 3-4 minutes to build (way more than yarn run) sadly I didn’t solved.
I noticed the development build takes the changes if I kill the packager process and restart it (ctrl+c and then exp start -c or exp start) but Reload, Live Reload and Hot Reloading from shake gesture doesn’t take changes.

Again, I guess this issue is related to the file watcher…

Hi @alfredopacino - if I’m understanding your stack overflow post correctly, it looks like you’ve fixed this issue by removing the packagerOpts.nonPersistent option from app.json. You said you had to add this in order to produce a release build – I am curious about that. What happens if you try to make a release build without this setting?

The error is “…socket hang up…”
Well, it’s pretty common error

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.