Datetimepicker Crashing on iOS in Development (Expo Go) but works on Production

Expo Managed Workflow, Expo 5.3.0 SDK 44, eas-cli/0.48.1 win32-x64 node-v14.15.0

Hello there,

As recommended by the expo docs, we utilize @react-native-community/datetimepicker installed with expo installs to make sure its a matching version (currently running 4.0.0) with our sdk.

It has worked without any flaws so far and we have used it for a couple of features and I’m currently working on a new feature that utilizes the same package with the same code for implementation on both iOS and Android.

My issue is that now the datetimepicker is not working for iOS on development, in any of the instances it is being used, even for the old features that remain unchanged and are still working on production.

As soon as I touch the iOS datepicker it crashes the Expo Go App, I don’t get any errors, warnings, nothing. Android is fine across the board.

I recently upgraded to SDK 44, not sure if that could be an issue, but I’ve tried resetting the cache, deleting the expo go app, reinstalling the node modules, updating my testing devices operating system but nothing so far …

I was hoping if you guys could offer some guidance on this.

Best,

Chaba

Hey @chabajosa, could you try creating a minimal reproduction of this with a new SDK44 project and the same version of the datetimepicker module. If you’re able to reproduce the crash reliably and consistently, it’d be appreciated if you could create a github issue.