CRNA and Expo not working

Hi all,

I am struggling for 2 days now to get an sample Native-App working together with the Android Expo app. I read a lot of errors regarding network adapter configuration and stuff like that but I am not able to understand the error.

I created an app like shown on the get-started page and installed the Expo app on my Android device.

After entering npm start the server starts and as soon as I hit the q-button the QR-Code is shown:

C:\Users\Markus\Desktop\wimp>npm start

> wimp@0.1.0 start C:\Users\Markus\Desktop\wimp
> react-native-scripts start

13:23:20: Starting packager...


Your app is now running at URL: exp://

View your app with live reloading:

  Android device:
    -> Point the Expo app to the QR code above.
       (You'll find the QR scanner on the Projects tab of the app.)
  iOS device:
    -> Press s to email/text the app URL to your phone.
    -> Press a to start an Android emulator.

Your phone will need to be on the same local network as this computer.
For links to install the Expo app, please visit

Logs from serving your app will appear here. Press Ctrl+C at any time to stop.

 › Press a to open Android device or emulator.
 › Press s to send the app URL to your phone number or email address
 › Press q to display QR code.
 › Press r to restart packager, or R to restart packager and clear cache.
 › Press d to toggle development mode. (current mode: development)

If I scan the QR the expo app tells me that I cannot connect because of an socket-timeout. Both, my windows machine where the server is running and my mobile device are both in the same WLAN.
Sniffing the network traffic using Wireshark I see that my mobile device sends SYN packets to the server but I never reacts with an ACK.

Any ideas what is going wrong?

Are you able to ping between a phone and a computer?

Also: I noticed you’re working on Windows and mentioned wireless connection - make sure that firewall is not blocking outcoming connections

Mmh. I can ping my mobile but from my mobile I cannot ping my windows machine. Just seeing ICMP-Echo Requests but not even one response.
Because it is all in my private network I expect that the windows firewall will accept everything or am I wrong?

You were totally right. Because my WLAN adapter was configured as “public” network profile it blocked all incoming connections with no exceptional rule.
I changed my adapter to use the “private” network setting and it worked fine for me. Thanks for pointing me into the right direction

Great, that’s exactly what I was thinking about. Happy to hear that you solved it!


This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.