Could not load app on Android

Recently, I upgraded exp sdk from 25 to 27 with a detached project. After fixing many issues, it is working successfully on IOS. While, on android, the device cannot load the app after I run exp start. There is a blue screen said Could not load app. Are you sure XDE or exp is running?. I even cannot track the issues. Anyone can help me? Thx

Hey @osir I’m so sorry you’re having problems! Can you tell me more about the operating system your machine is running? Have you updated exp to the latest version?

@jimmylee Thx for replying me. I found the reason, the url showing from the terminal after I run exp start is not same as the ExponentBuildConstants, I tried to manually change the ExponentBuildConstants to the same as from terminal, it would work. But I don’t think it is the way to fix this issue, I know ExponentBuildConstants might change rebuild the app, any ideas on this?

1 Like

Great, nice work :slight_smile:

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.