Could not find host.exp.exponent:expoview:22.0.0 error after Eject

I have developed an application with expo but I also needed which is not supported by Expo.
I tried detaching but that caused lots of issues like social media logins were not working, camera/image selection not working and so on.

And then i tried ejecting the application with “npm run eject”. Then i run the command “react-native run-android” and it gave me this error

Could not resolve all dependencies for configuration ‘:app:_debugApkCopy’.
Could not find host.exp.exponent:expoview:22.0.0.

hey @sandeepkasani, did you follow the steps for detaching & using ExpoKit in the expo guide? your app should work the same with everything you’ve already implemented with expo, the only difference is now you’ll have to continue development inside xcode/android studio.

one of the trickier parts is making sure xde/exp is running in the background while you build the project with xcode/android studio. Would you mind expanding on the issues you had after detatching & steps you took to detatch?