`Constants.manifest is null` error with expo run:ios. Working fine on other local machine.

Hi everybody,

I am completely lost after a few days of researching and trying everything.
Since a few days, I get the error
Constants.manifest is null because the embedded app.config could not be read
when running expo run:ios. It worked in the past but at some point it stopped working and I can’t pinpoint why. It is especially weird that my colleague can run it perfectly fine on his machine.

What I am using:

  • OS: MacOS BigSur 11.6
  • SDK: 42
  • node version: v14.17.1
  • npm version: 7.24.2
  • XCode: 13.0
  • react-native: 0.63.4

What I tried so far:

  • Delete node_modules, npm cache, watchman, metro-cache, haste-map folders, start expo with --clear
  • delete the app from the iOS simulator
  • reset the iOS simulator
  • delete the .expo folder in the project folder
  • delete the ~/.expo folder
  • uninstall expo-cli and install it again
  • delete the ~/Library/Developer/Xcode/DerivedData folder
  • clone the repository again

I have no idea what else I could do.
Looking forward to any help!

Regards,
Okamikun

Update: After updating to SDK 43, it is working again.

Additionally, I added a .npmrc file with legacy-peer-deps=true to the project folder and ran the upgrade with EXPO_BETA=1 expo upgrade --npm.
When doing npm install I always used legacy-peer-deps because of one of our packages, so that setup was also necessary for the upgrade.

1 Like