Constantly have to restart the client to load new project

Almost without fail, whenever I open a new project to test in the client, I get a white screen and spinner. I have to kill the app, and then restart the app and then reopen the project. then it works.

Why is this??

iPhone 7,
Client Version

Hi @dovc

What version of the Expo CLI are you using?

Also, it just hangs indefinitely on the white screen/spinner?

Client version

Yes it just hangs indefinitely.
This behavior happens for everyone on our QA team.

Here is a video of the experience.
I start the project - Fails

Go back to Expo, Restart the project - Fails

Kill Expo

Back to Expo, Start the project - Success.

(Attachment ScreenRecording_03-27-2019 14.MP4 is missing)

any help @charliecruzan??

Sorry @dovc, it’s very hard to help without a reproducible demonstration. What version of the CLI (not the Expo Client app) are you using? Is there any sort of output in the logs that may indicate a source for the problem?

I can give you a demo to reproduce if you would like to jump on a video call.

I do not use the CLI - I am a product manager - however we use CLI 2.4.1

This happens in the Client App - where would I see those errors?

You may see the errors in your dev console if you’re running it locally (as with expo start), but since you’re not using the CLI then I don’t think that’s part of your workflow.

So this happens with projects that others have published, and then you’re simply trying to view them? And by CLI 2.4.1 you mean Expo CLI? I’d recommend upgrading to the latest version (2.14.0), and ask if the dev publishing the project sees any errors when running locally (as with expo start)

I am also facing this issue. I am using the latest expo cli on Windows 10 (just updated it via npm today) and the latest android app on a google pixel 2 xl.

There are no errors in the command prompt or the chrome browser tab that opens when I run it locally. If i make code changes, all I get is the splash screen and “Downloading JavaScript bundle 100.00%” nothing else. The app never starts.

I have to force kill the android app, relaunch expo and then it works.

Hey @zoonosis!

Does this happen with every Expo app you create, even a brand new one?

Hi @charliecruzan
I tried it with a brand new app using expo init and everything works as it should.

I dont understand though, my app does not have any bugs…why does it only run once?
What should I do?


I went and started working on my current app again…and for some reason everything is ok now. I can change code and it rebuilds and runs on its own
Its like starting a new expo app fixed it somehow, not sure why

Does that makes sense to you guys?

This problem is happening again