companyName not being set in requiredAttributes for was submit to iOS store.

I am in the bare workflow, just ejected last week and everything builds fine for both android and iOS, no issues there. However, I need to submit my app to the App Store to generate an app-specific shared secret to setup subscriptions through Revenue Cat.

When I run the eas submit --platform iOS command, everything goes well till it errors out with this message: :heavy_multiplication_x: Failed to create App Store app met-tree-nome
The provided entity is missing a required attribute - You must provide a value for the attribute ‘companyName’ with this request
Please visit and resolve any warnings, then try again.

Your documentation say that for new app submissions with a brand new developer account with no previously submitted apps, that these attributes will be automatically created for me. Yet it is not doing that in this case. How do create the companyName attribute and is that in eas.json? There is no documentation for this structure and I have tried every possible object permutation for adding that into the app’s eas.json but it gets blocked specifically because the eas.json isn’t correct.

We are using the eas-cli version 0.34.1

Hey @allenstudiosllc, please see this section of the docs Configuring EAS Submit with eas.json - Expo Documentation