CLI Installed - No way to create a new project ๐Ÿ˜ž

Hello everyone, any tips and suggestion to a poor designer who likes to code but not that much to understand this?
Iโ€™m not able to create a new project.

Thank you!!


expo is not in your PATH, so the shell canโ€™t find it when you type the command.

See if this thread gives you some ideas for sorting that out. Just bear in mind that youโ€™re using bash where the other thread is about zsh.

The concepts are the same. Only, you should add the line to /Users/username/.profile instead of .zprofile

1 Like

@wodin thanks a lot! I will work on that today and hopefully, I hope to be able to fix that!

1 Like

Sorry, I forgot to link the thread:

@raffaelevitale, let us know if you managed to sort out your PATH problems.

@wodin still not solved, Iโ€™ve changed to .zsh

Dear Wodlin, after typing

export PATH=PATH:(npm bin -g)

Iโ€™m able to work! How can I set it as a standard path? After closing the terminal, seems like I should rewrite the same command :frowning:

If you have switched to zsh you can just create a file in your home directory called .zprofile and add that export command to it. Then close and reopen your Terminal. The equivalent for Bash would be to add that command to a file called .profile in your home directory.

Just make sure you have the dollar signs in there. For some reason they are not included in your comment above.

Actually, because the command outputs some extra info not relevant to updating the PATH it would be better to tweak it a bit:

export PATH=$PATH:$(npm bin -g 2>/dev/null)

The easiest way to create the .zprofile file is to run this in your Terminal:

echo 'export PATH=$PATH:$(npm bin -g 2>/dev/null)' >> ~/.zprofile

(Again, the equivalent for Bash it the same, but in the .profile file):

echo 'export PATH=$PATH:$(npm bin -g 2>/dev/null)' >> ~/.profile

Awesome!!! Thank you so much!!

1 Like

I still donโ€™t know why your quoting seems to strip out the dollar signs! I hope nobody tries to copy from the quote instead of the original comment :slight_smile:

Glad itโ€™s working for you now.

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.