CFBundleDisplayName not working for me (iOS)

Hey everyone,

I’m working on an app that has two words for its name and I noticed that once I install it from TestFlight the app name looses its space between the two words - I’ve tried to setup the infoPlist config in the app.json file settings up CFBundleDisplayName - but it didn’t help.

Any ideas how to solve this?



1 Like

Isn’t it coming from your app.json version property?

Not sure I understand what you mean…

A property could override another?

Yes, look for infoPlist in

I have the same issue. Had to detach app and set display name in Xcode.

It sounds like it was working at some point. I’m googling around to investigate a solution, since I too have an app with two words. I havn’t tried anything yet, I’ll post back here if I have luck.

1 Like

@nirpeled curious, did you see this issue in a simulator build? I just tested a simulator build with the infoPlist described and it properly has the space between the two words.

@nirpeled so it turns out that this is an iOS & Test Flight thing. Nothing to do with expo. The ‘dot’ next to the app actually reduces the space for the app name. And iOS removes spaces from app names if it goes into truncation mode.

See the following links. I’d recommend to test the simulator version and you’ll discover that the spaces are intact. I’m going to remove my CFBundleDisplayName option in my app.json b/c I think I don’t need it to have this space.

1 Like

Oh wow that’s awesome, I was afraid I was doing something wrong.

Thank you so much for your help :clap:

1 Like

Glad you got it resolved! Thanks for the assist, @qmitchell!

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.