Can't run new expo app in iOS simulator


So when executing ‘yarn run ios’ or ‘npm run ios’ in the terminal I’m getting this error:

Can't determine id of Simulator app; the Simulator is most likely not installed on this machine. Run `sudo xcode-select -s /Applications/`
Unable to verify Xcode and Simulator installation.

Ive tried running the command, but that does not fix it. I have several other applications which are bare react-native and they are runnning fine on simulator. One time it fixed itself after a restart, but now its not working again. What can be the issue here? As I said before i have multiple apps which I’m developing in my company so Xcode / Simulator can’t really be an issue. Works fine if I just do “npm run start” and run the app on a device by scanning the barcode.

This is the suggested place to post issues etc, but are anybody reading this?

Hi @frankbolviken

Yes, this is the place to ask. You could also try discord.

Unfortunately there are more people asking questions here than answering them. But also, weekends are quieter, so you might have more luck asking questions during the week.

I don’t know what’s causing your problems, but what do you get if you run the following in the Terminal?

osascript -e 'id of app "Simulator"'

I get:

Poking around here turns up another xcode-select command you might try. I have no idea whether it will help, though:

So I would try running sudo xcode-select --reset and see if that helps.

Hi! Thanks for you reply. I was already pointed in that direction yes looking at some other questions on google, and the output was

osascript: can't open default scripting component.

The most upvoted answer to this question is reboot, but that does not help. Or, previously it worked after a reboot but now it never works :frowning: So current theory is that something is messed up with my Big Sur installation :frowning:

xcode-select --reset didn’t help

Reinstalling the OS might help :man_shrugging: