Can't run fresh expo app

I have been trying to start a new expo app for days and i can’t get anywhere. There’s always a new error. I have tried everything from upgrading ruby version to switching node versions, even switched macbooks, but i have the same issue.

I create a new app using:
npx create-expo-app name-of-app

And then i run it by npm start

Then, when i press “w” for webview, i get the message that i need to install react-native-web@~0.18.9, react-dom@18.1.0, @expo/webpack-config@^0.17.2 in order to add web support.

So like it says, i run:

npx expo install react-native-web@~0.18.9 react-dom@18.1.0 @expo/webpack-config@^0.17.2

But that fails, with the error:

zsh: no matches found: @expo/webpack-config@^0.17.2

So then i try to install the the two first ones with npm i, and then i install @expo/webpack-config individually without version number.

Then, when i try to run the app in web again, the browser console is full of errors that say:

bundle.js:43008 Uncaught Error: Cannot find module ‘inline-style-prefixer/lib/plugins/backgroundClip’


Uncaught ReferenceError: process is not defined


Module not found: Can’t resolve ‘inline-style-prefixer/lib/plugins/backgroundClip’

So then i try to npm install inline-style-prefixer, even delete node_modules and package-lock.json and npm i again, but it’s the same result every time. I have no clue what to do anymore. I can’t get anywhere!

Also, when i try to npm run ios i get this error:

Error: xcrun exited with non-zero code: 2
An error was encountered processing the command (domain=NSPOSIXErrorDomain, code=2):
Unable to boot device because we cannot determine the runtime bundle.
No such file or directory

Does anyone have a clue what is going on? Am i doing anything wrong? I can’t find any answers and i’m so lost and i want to give up

I was having this similar background clip error as well. Stumped me for days. What finally worked was following these steps here for my webpack file:

Once I added the babel bundler and image bundler, and installed the babel-plugin-react-native-web package, it fixed my issue! :slight_smile: Hope this helps!

Hi @jujasen

This is a complaint from zfs about what it sees as a pattern for a filename/set of filenames. It’s some sort of safety feature. When bash gets a pattern that doesn’t match any files it just leaves it as-is and hands it to the command you’re calling (in this case npx) as an argument. zsh, on the other hand, gives you an error like the above when there’s no match.

If you want zsh to pass the “pattern” to the command as-is you will need to quote it:
npx expo install 'react-native-web@~0.18.9' 'react-dom@18.1.0' '@expo/webpack-config@^0.17.2'

Alternatively, since expo knows what versions to install you can just leave those off:
npx expo install react-native-web react-dom @expo/webpack-config

As for why you are getting those backgroundClip errors, I don’t know, but you shouldn’t have to install inline-style-profiler as a direct dependency.

Do you get the same errors if you create a new app, then install the web dependencies as above without installing inline-style-profiler? If so, please send the output of npx expo-env-info.

I am also not sure about this error, but it seems like maybe there’s something wrong with your Xcode install.

I would just ignore expo run and rather use Expo Go or a development build for development.