Can't publish or run the app in dev

I suddenly can’t do anything on expo. When I try to start my app in the expo client in dev, it gets stuck on New update available, downloading…

If I try expo publish, it is stuck on Building iOS bundle and nothing else happens.

Is there any chance that this is related to the expo server?

  1. SDK Version: 39
  2. Platforms: Android & iOs

As I wanted to make sure it wasn’t because of my code, I tried to publish from another computer that had older code that I knew worked. Same issue.

Also, when attempting to publish from a mac I get this message both when trying to publish and when simply trying to launch the app in dev:

jest-haste-map: Watchman crawl failed. Retrying once with node crawler.
  Usually this happens when watchman isn't running. Create an empty .watchmanconfig file in your project's root folder or initialize a git or hg repository in your project.
  Error: Watchman error: too many pending cache jobs. Make sure watchman is running for this project. See

hi there! please share your project if you believe this is a bug in expo so we can try to reproduce this.

Hello, how do you want me to share my project? You mean sharing the code?

yes, you can post it on github. or if you can’t share your code, then create a mcve and share that

Hi. Recently I had symptoms like this on my Mac. Here’s what I eventually found and what fixed it.

Seems File System Events had stopped working. I had noticed that Finder did not seem to refresh as it should either, but don’t use it that often, so didn’t think too much about it. Then put 2 and 2 together and decided a reboot was in order. That fixed it.

Whether your problems are caused by the same thing, I don’t know. But maybe see if watchman watch-del-all helps at all.

I’m not sure this latest issue is related to the problem in your original post. I have recently been seeing this New update available, downloading… issue too, but have managed to get past it by restarting the app and the dev server a few times.

It works neither on my Mac nor PC though :frowning: .

Do you get the same watchman errors on both?

Another thought crossed my mind:

I have occasionally seen watchman trying to watch someone’s entire home directory. This also happened to me once and I think it was around the time I was having trouble with File System Events.

If you have several JavaScripts projects and other things in your home directory, including several node_modules directories, and watchman is trying to watch the whole tree then it can take forever trying to scan them. At least that seemed to be happening when I found watchman watching my whole home directory. That could cause the symptoms you’re seeing. i.e. watchman not responding in time and therefore rebuilds of your project not working.

Have you tried running watchman watch-del-all? If so, did it by any chance print out a path that is not one of your Expo projects?

Okay, so I decided to let it alone last night to figure it out in the morning. And this morning:

  • Starting the app in the expo client in dev works on PC
    I tried to restart my computer yesterday to no avail, so I am not sure why waiting longer did the trick.
  • Starting the app on Mac is still stuck on New update available
  • Publishing still gets stuck, on both PC and Mac.

Please note that this is without touching a line of code.

I tried watchman watch-del-all and restarting the mac without success :slightly_frowning_face:
watchman watch-del-all only printed back my project’s directory.

Finally: no I only get the watchman error on mac, not on PC.

I finally managed to get publishing to work by doing this:

I called expo install expo-updates (as I needed the package), and it is once more stuck on New update available, downloading.

I will try to redo the process of deleting node-modules, but I think there is something wrong with how packages get updated.

Edit: Deleting node_modules and caling npm install fixed it again… I still don’t know what is causing this. I can only hope I won’t have to delete node_modules everytime I want to add a package.

From what I have seen myself and what others have posted about this, it seems like a race condition in the client. So while removing node_modules and reinstalling them might seem to work, it’s probably just random luck.

Try killing the Expo experience on the phone and opening it again a few times in a row.

Killing and re-opening Expo is part of my dev routine since a few weeks already. Without that it would not launch my app at all. :slight_smile:

This issue is different. It would get stuck on New update available, downloading… forever, no matter how many time I closed and reopened expo.

The fact that it won’t let me publish at all is also new.

Try to start a new/clean emulator instance by wiping the data on it. I had the same issue on PC with Android Studio.

The only way I could get it to work was to go into Android Studio and on the Tools/AVD Manager screen I clicked the Wipe Data on the device that I was having issues with.


I hope that helps.

Thanks for the suggestion :slight_smile:
Unfortunately, the problem happens on a physical device.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.