Can't properly configure associatedDomains for deep linking in app.json

I’ve tried to implement associated domains for iOS on at least 3 different bundles I’ve submitted but can’t seem to get it working, and the documentation regarding configuration in app.json is very minimal. When I use apple’s AASA validator, it tells me “no apps associated with URL” but the AASA config is valid, so it has to be how I have it in the app.json.

For clarity’s sake, here’s my AASA file:

// I've tried both the appID and my teamID
   "webcredentials": {
       "apps": [""]
    "applinks": {
        "apps": [],
        "details": [{
            "appID": "",
            "paths": ["/openapp/*"]

And my app.json config:

"associatedDomains": [

What am I doing wrong?

Hey @metoo,

Can you debug the ipa and see what is actually being listed in the info.plist?



1 Like

Turns out I’m the idiot (hate when that happens)
I’d been testing whether the link worked or not by plugging the link into safari instead of tapping on it in notes or something. We live and we learn.

Some of us live more than we learn ¯\_(ツ)_/¯


Haha, no worries! Just glad you figured it out!

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.