Can't 'pod install' on ejected app

I want to eject from expo because I need to use fbsdk in order to track app events.

for this, as I never done ejects before I created a new app to make my testing but I get an error that Im unable to overcome by myself.

This are the steps I’ve made:

I created an app with expo init.

I eject the app doing: expo eject .

I choose the black template. And also use reactnative + expo but when this step finishes I get a message that told me that expokit wasn’t installed and that I should do it manually in order to complete detach. So I do npm install expokit@31.0.2.

next I go to the ios directory and I type pod install and this get stucked some minutes in: re-downloading: ExpoKit from, tag `ios/2.9.0

and after those minutes I got the following message:

[!] Error installing ExpoKit
[!] Failed to download ‘ExpoKit’.

I dont know what to do next. When I move to the following step in xCode that is suggested by this guide: I obviously cant make the build.

Can you help me guys?

Thanks in advance.

Hey @fontsanguinetti,

Can you try running pod repo update and then pod install?



Thanks @adamjnav, I tried what you suggested with still no sucess. Im stucked here :face_with_raised_eyebrow:

Ah. This may help you: Pod install fail to download ExpoKit 2.9.0

1 Like

@adamjnav this time it worked. So much thanks for your answer, it helped me a lot :pray:t3:

1 Like

Glad to be of service!

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.