Can't load my own published app

I have 2 published apps in my profile. I’ve been using them without a problem for months. This morning, I tried to open them (in my profile, under published projects) and got the error “There was a problem loading the requested app”…“The experience you requested is not viewable by you.” How is that even possible?

One other piece to the puzzle. I’ve had others log into my account on other phones. They’ve been doing that for anywhere from 6 months ago to one week ago. They can still open the apps, but I can’t.

Any ideas? (I’m on IOS.)

EDIT: I just realized my Expo client app just auto-updated to Version 2.9.0 last night. Could that be the reason it’s failing?

Found a solution. For those that experience this, I had to uninstall and reinstall the Expo client.

To the Expo devs: I suspect there’s a bug associated with client authentication associated with the upgrade. Might be worth a look.


cc @quinlanj

Thank you so much for replying back with your fix! I have an interview coming up where I was going to utilize Expo and it breaking like this gave me a heart attack. Re-installing the client was the only thing that worked for me.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.