Can't install expo-cli, hangs on installing @expo/traveling-fastlane-linux@1.9.9

I’m trying to install expo-cli so I can complete a React tutorial Introduction · React Native, but when I do so using npm install -g expo-cli, the installer hangs:

[ …] \ extract:@expo/traveling-fastlane-linux: sill extract @expo/traveling-fastlane-linux@1.9.9 extracted to C:\Users\edkol\AppData\Roaming\npm\node_modules.staging@expo\traveling-fastlane-linux-db114743 (362890ms)

This is the last message I get from the installer; then it just hangs and I’ve let it run over 15 minutes to no avail. How can I complete the installation of expo-cli so I can use React?

Thanks! :slight_smile:

Hello @ekolis am having the same problem please do you mind telling me how to solve it ?

I have same problem can you share solution?

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.

Perhaps downloading the package failed and the local npm cache is now corrupt somehow? Can you try running npm cache verify and then install again?

1 Like

Still, after clear cache there is same issue.
Please give a final solution.

I spent a few days on the same issue.

I attempted to install expo-cli on Windows 10 pro

Expected Behaviour
I ran npm install -g expo-cli on a Windows 10 Pro and It should install expo cli successfully

Observed Behavior
Installing stopped with the following warnings

npm WARN tarball tarball data for @expo/traveling-fastlane-darwin@1.11.4 (sha512-1rNq4yMHGfmYhUJuBH5lKpmHVAa5QjgXbv3MoMqsFrlnwzDaq4qHSs6s/RWHw+gmk5lASEhmW32ALArAxX9ceA==) seems to be corrupted. Trying one more time

Nodejs v10.13.0
NPM v6.13.6
Windows 10 pro

I got this fixed by downgrading to expo-cli@3.5.0

1 Like

Follow the steps :-

  • First, run npm cache verify.

  • Open Windows PowerShell as administrator and run npm install expo-cli --global --no-optional command.

How do you downgrade?


npm i expo-cli@3.5.0

1 Like

hi guys
pls help me
i have problem with install expo-cli
the cmd hangs !!!
i do everything but not working

run npm i expo-cli@3.5.0

Ubuntu 20.04 Focal Fossa here:
Was having the same problem even after doing
sudo npm install expo-cli --global

Step 1:
npm cache verify

Step-2: (now do it)
sudo npm install expo-cli --global

Worked for me. Installed the version 3.22.1 !