Can't find variable:path

As in all my other topics, I am doing an Expo app, and after including some new files to it and working until yesterday night, now I am recieving this error everytime I want to run it on my android device.

As you can see, I get that and I haven’t been able to find an answer anywhere in the internet, so I was hoping someone could please help me, because I have a due date and it is really important.

I have tried to do the following:

  • Stop the packaging and start it again
  • A restart cleaning the cache
  • Changin the tunnel from local to lan
  • Plugging and unpluggin my phone
  • Restarting the computer and the phone
  • I have checked that all nodules are well installed

I have no more options to do and I am really desperate.

If you could give me a clue, please that would be awesome.

Thank you very much :slight_smile:

Hi @guardme,

Could you share some more information, like you’re environment (run expo diagnostics)

Are you able to succesfully run and open a new expo init project?

Let me know!
Charlie

Hi @charliecruzan,

When I run expo diagnostics I get the following:
image

And refering to the second question, I created a new project called Example, and it was succesfully created:
image

And moreover, I have tried to run it, and it runs nicely:
image

So I do not know what is going on. The last thign I wanna do is to copy and paste everything into a new project…

Thank you very much

It’s hard for me to say what could be the cause of this, without being able to reproduce it on my end. Since you’re able to create and run another project, it’s not your environment.

I believe this is an issue somewhere in your code, my best suggestion is to go back through your recent changes before this issue cropped up to find where this is originating.

-Charlie

The thing is that it worked fine all the time, until I ran it and it crashed without any reason…

I tried removing all the things I changed so I obtained the version that worked and it’s still crashing. If I find somehow what is happening I will reach this Forum to give a solution, but I believe that in the process of running some file was modified by the command expo start and it came out this way.

Thank you :blush:

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.