Can't delete or force update a secret

Hi, I’m having issues creating, updating, and deleting secrets with eas cli.

I’ve successfully created an account level secret with :
eas secret:create --scope=account --name=WHATEVER --value=a_secret

Now I want to update it to a new value, but when I run:
eas secret:create --scope=account --name=WHATEVER --value=a_new_secret --force

I get an error:
CombinedError: [GraphQL] Account not found

So I thought I could just delete and recreate it myself, but when I try to delete with:
eas secret:delete --id=my-secret-id
and choose yes to proceed, I get an error:
Error: Expected operation of type "query" but found "mutation"

Finally I tried to do the same with a project level secret, but I can’t even create one of those…

eas secret:create --scope=project --name=WHATEVER_PROJECT_SECRET --value=a_secret
returns:
Error: Expected operation of type "query" but found "mutation"

Anyone else have the same issue or can suggest a fix or workaround?

Thanks

Are you using the latest eas-cli? If this issue persists with the latest version of eas-cli then let us know. You can also work around this by modifying secrets through the website

Thanks for the reply. Sorry, I forgot to mention:

> eas --version
eas-cli/0.27.0 darwin-x64 node-v15.11.0

Unfortunately modifying secrets via the website won’t work for me; I’m trying to automate a build process

how are you authenticating with eas-cli?

Thanks for this report! I’ve identified the problem and will have a fix out soon!

1 Like

This is now fixed in the latest version of eas-cli. Please upgrade your local CLI and your CLI in CI for this to work! Thanks again for using Expo and EAS <3

1 Like

Awesome, thanks for the quick turn around. Can confirm that it’s all working as expected now :smiley: