Can't connect to expo servers

Hello, i’ve just installed expo and initialized my first project with expo init. Now when trying to start my app with npm start i’m getting this error: “There seem to be a transient problem with Expo servers, using the cached dependency map (bundledNativeModules.json) from the package “expo” installed in your project.”

My expo diagnostics info:
Expo CLI 4.11.0 environment info:
System:
OS: Windows 10 10.0.18363
Binaries:
Node: 12.18.3 - C:\Users\u99rlx\AppData\Local\nvs\default\node.EXE
npm: 6.14.8 - C:\Users\u99rlx\AppData\Local\nvs\default\npm.CMD
IDEs:
Android Studio: Version 2020.3.0.0 AI-203.7717.56.2031.7621141
npmPackages:
expo: ~42.0.1 => 42.0.3
react: 16.13.1 => 16.13.1
react-dom: 16.13.1 => 16.13.1
react-native: https://github.com/expo/react-native/archive/sdk-42.0.0.tar.gz => 0.63.2
react-native-web: ~0.13.12 => 0.13.18
Expo Workflow: managed

Hey @rluyckx, can you try deleting your node modules and re-installing them?

Thanks for the reply. I deleted my node modules and reinstalled them but I still have the same problem. I tried creating another project but I get the same error.

When I run expo doctor, I get the following.


The app runs on my android phone but when I try opening it on an emulator I get the following:
“Couldn’t start project on Android: Error running adb: unable to get local issuer certificate
Error running adb: unable to get local issuer certificate”
I tried multiple emulators and followed all steps on the Expo docs to set up an emulator

I also got this earlier. I’ve never seen it before.

Hey wodin, were you able to resolve this?

I haven’t seen it again, but I haven’t done much with Expo in the last few days.

I think I got it when running expo init or maybe expo install .... I’ve just tried expo doctor now and did not get an error:

% expo doctor
🎉 Didn't find any issues with the project!

I’ve also just tried expo init and expo install react-native-svg react-navigation now, also without errors.

Or maybe it was expo upgrade.

The error message is about SSL certificates. In particular, the local system (your computer) does not have, in its trusted certificate store, the certificate of the CA that signed the remote server’s certificate. The problem is I’m not sure which remote server this is exactly. Especially when you run adb.

Ah! I think I got that error while trying out someone’s code in order to try to help them with a problem. They were using npm, so I used that too. I normally use yarn instead of npm. But I’ve just tried to create a new project using npm and also tried expo install ... in that project, but I did not get the certificate error.

I would recommend you just use turle-cli and run your own build servers from there. This reduces ONE dependency.

Have you tried eas build --local? I think that’s meant to replace turtle-cli but I could be wrong.

But anyway, turtle-cli or eas build --local or expo build:* are not what @rluyckx was trying to run.

No, but afaik eas is a paid service. For now, I just want to use Expo as a way of getting off the ground as quickly as possible and have HMR working out of the box, plus the use of snacks.

However, the end goal for my team is to ensure we’re not dependent on Expo and ensure we can run things ourselves as soon as possible.

Also what do you think @rluyckx is running? It sounds like he is trying to do an expo build

EAS Build is currently a paid service for building your app on Expo’s servers. There will be a free tier in future. But eas build --local is basically a local version of EAS Build. It builds on your own machine, so it’s not a paid service.

Try eas build --local and custom dev clients etc. :slight_smile: I think you’ll be impressed. You’ll end up with smaller apps and the ability to use native dependencies (although this is still new, so you might need to write a config plugin).

Read their comments. No mention of expo build:

That’s good to know.