Cannot run ios after ejecting a bare expo project


I created a bare expo project and ejected immediately after that. Then I run npm run ios but I get this error

➜ test_app git:(master) ✗ npm run ios

> test_app@1.0.0 ios

> react-native run-ios

info Found Xcode workspace "testapp.xcworkspace"

info Building (using "xcodebuild -workspace testapp.xcworkspace -configuration Debug -scheme testapp -destination id=79196FB8-2668-4A20-B60A-B21A38C2D84D")

success Successfully built the app

info Installing "/Users/myMac/Library/Developer/Xcode/DerivedData/testapp-gvlvihosbzycfcaiyidncpthmvvn/Build/Products/Debug-iphonesimulator/"

An error was encountered processing the command (domain=IXUserPresentableErrorDomain, code=1):

This app could not be installed at this time.

Could not install at this time.

Failed to chmod /Users/myMac/Library/Developer/CoreSimulator/Devices/79196FB8-2668-4A20-B60A-B21A38C2D84D/data/Bundle/Application/305CB88B-7396-4B77-B875-A3166539FE58/ : No such file or directory

Underlying error (domain=MIInstallerErrorDomain, code=4):

Failed to chmod /Users/myMac/Library/Developer/CoreSimulator/Devices/79196FB8-2668-4A20-B60A-B21A38C2D84D/data/Bundle/Application/305CB88B-7396-4B77-B875-A3166539FE58/ : No such file or directory

info Launching ""

error Failed to launch the app on simulator, An error was encountered processing the command (domain=FBSOpenApplicationServiceErrorDomain, code=1):

The request to open "" failed.

The request was denied by service delegate (SBMainWorkspace) for reason: NotFound ("Application "" is unknown to FrontBoard").

Underlying error (domain=FBSOpenApplicationErrorDomain, code=4):

The operation couldn’t be completed. Application "" is unknown to FrontBoard.

Application "" is unknown to FrontBoard.

What I found is the folder 305CB88B-7396-4B77-B875-A3166539FE58 doesn’t exist under Bundle/Application

When I run build in xCode, I get this error

error: Resource "/Users/myMac/Library/Developer/Xcode/DerivedData/testapp-fnnkciaavkzexmcwuxnpubszxupr/Build/Products/Debug-iphonesimulator/React-Core/AccessibilityResources.bundle" not found. Run 'pod install' to update the copy resources script.

I go to the ios folder and run pod install successfully but I still get the same error when trying to build the project.

Expo diagnostics

Expo CLI 4.1.6 environment info:
      OS: macOS Mojave 10.14.6
      Shell: 5.3 - /bin/zsh
      Node: 15.5.1 - /usr/local/bin/node
      npm: 7.3.0 - /usr/local/bin/npm
      CocoaPods: 1.10.1 - /Users/myMac/.gem/ruby/2.6.0/bin/pod
      iOS SDK:
        Platforms: iOS 13.2, DriverKit 19.0, macOS 10.15, tvOS 13.2, watchOS 6.1
      Android SDK:
        API Levels: 23, 27, 28
        Build Tools: 27.0.3, 28.0.3
        System Images: android-28 | Google Play Intel x86 Atom
      Android Studio: 3.2 AI-181.5540.7.32.5056338
      Xcode: 11.2/11B52 - /usr/bin/xcodebuild
      expo: ~40.0.0 => 40.0.1 
      react: 16.13.1 => 16.13.1 
      react-dom: 16.13.1 => 16.13.1 
      react-native: ~0.63.4 => 0.63.4 
      react-native-web: ~0.13.12 => 0.13.18 
      expo-cli: 4.1.6
    Expo Workflow: bare```

The linked packages only work with the workspace. When I used the .xcworkspace file, I could build the project.

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.