Cannot get tunnel connection to work (local does work)

I am working locally and using CLI to publish so I can view in the Expo Client App before I publish the project. At first I could not get anything working, though on my computer it said Tunnel Ready and gave me the URL and QR code. As I would open those on the Client App they would consistently never connect.

I changed it to local since I am on the same wifi as my devices and it works most of the time.

I really want the tunnel so someone else in a different state can view the app reloads as I do some development.

As mentioned, I followed the directions and it says Tunnel Ready - what else should I look at? I am using Mac OSX and the firewall is turned off.


Hey @phillipofferboxx,

What version of the cli are you using?



And @adamjnav - to make sure, if this is working, the tunnel should work while on the same wifi or if I take my cell phone off wifi and just use LTE data, right? And then also someone in a different location can load up the app through tunnel as well - right?

I saw 3.0.10 came out just over a week ago, is the version maybe a problem?

Thanks again!

Hi @phillipofferboxx

I am running expo-cli 3.0.10. I can run expo start --tunnel, turn off the wifi on my phone while leaving the mobile data enabled, scan the QR code in the Expo app and work as if I were connected via LAN.

I have in the past had two devices connected at the same time (over the LAN but I see no reason this should not work via the tunnel too.)

The tunnel URL should look like exp://
As a test, if you change exp:// to http:// you should be able to connect with a web browser, which should download some JSON which looks similar to the contents of app.json. Does that work for you?

Well, I figured it out after searching those error messages. It turns out localhost was not in my /etc/hosts file. When I added it, things are working well!

Maybe an idea to add to some help documentation because nothing else indicated that could be the issue.

1 Like

The other option would be for expo to use instead of localhost.

Yeah, that would work out, in case people have “localhost” mapped to something else or just some other hosts mapping.

Glad I figured this one out. I am excited to share my work with my remote team members.

1 Like

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.