Cannot 'Expo login' request failed with status code 502 (proxy problem)

Hello everyone,

I need to log into my expo account to be able to use expo push notifications, but through EXPO CLI I cannot enter my expo account.
If I try to enter my expo account via browser (chrome), everything is fine.

I work for a company and I use a proxy to connect to the internet.
I think it is a problem in the proxy or firewall configuration but I am not sure.
If it is a proxy or firewall configuration problem I need to understand the configurations to tell my bosses.

I tried to use a free internet connection and everything works perfectly, but i can’t use this internet connection at work.

I am attaching all my logs, and my study of my internet connection through Wireshark (Wireshark - Wikipedia).

Expo diagnostics
Expo CLI 3.27.14 environment info:
OS: Windows 10 10.0.19041
Node: 14.13.0 - C:\Program Files\nodejs\node.EXE
npm: 6.14.8 - C:\Program Files\nodejs\npm.CMD
Android SDK:
API Levels: 26, 27, 28, 29, 30
Build Tools: 29.0.2, 29.0.3, 30.0.0, 30.0.1, 30.0.2
System Images: android-29 | Intel x86 Atom, android-29 | Google APIs Intel x86 Atom, android-30 | Google APIs Intel x86 Atom, android-30 | Google Play Intel x86 Atom
Android Studio: Version AI-193.6911.18.40.6821437
expo: ^38.0.10 => 38.0.10
react: ~16.11.0 => 16.11.0
react-dom: ~16.11.0 => 16.11.0
react-native: => 0.62.2
react-native-web: ~0.11.7 => 0.11.7
Expo Workflow: managed

After entering ‘expo login’
Enter my email address and password.
I got this error…

Request failed with status code 502
Error: Request failed with status code 502
at createError (C:\Users\marco.mencarelli\AppData\Roaming\npm\node_modules\expo-cli\node_modules\axios\lib\core\createError.js:16:15)
at settle (C:\Users\marco.mencarelli\AppData\Roaming\npm\node_modules\expo-cli\node_modules\axios\lib\core\settle.js:17:12)
at IncomingMessage.handleStreamEnd (C:\Users\marco.mencarelli\AppData\Roaming\npm\node_modules\expo-cli\node_modules\axios\lib\adapters\http.js:237:11)
at IncomingMessage.emit (events.js:326:22)
at endReadableNT (_stream_readable.js:1252:12)

If I run ‘expo doctor’ I got this…

Warning: could not reach
Warning: could not reach

We couldn’t reach some of our domains, this might cause issues on our website or services.
Please check your network configuration and try to access these domains in your browser.

Didn’t find any issues with the project!

With Wireshark (Wireshark - Wikipedia) I have analyzed my network traffic under proxy.
I noticed this:

If I run ‘expo login’

If I run ‘expo doctor’

All these addresses are unreachable through expo cli but perfectly reachable via browser (chrome).

Other information

  • I made all the proxy settings (environment variables and various proxy configurations …) and they are correct.

  • I use a windows computer.

  • I visited all expo forum but without finding the solution

1 Like

Expo works under corporate networks with proxies.
You can see the connection problems run ‘expo doctor’, you just need to enable the corporate network.
Good luck

1 Like

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.