Cannot build or publish: Problems validating asset fields in app.json

Does anyone know the root cause of this problem?

• cannot access file at ‘./logo.png’ for field ‘icon’.
• cannot access file at ‘./splash.png’ for field ‘splash.image’.

I have tried changing the files, changing their location, deleting node modules and nothing has worked.

1 Like

Where are your files located in the project?

I’ve put them in an img folder.

so the error i get when i run exp start/publish is:

[exp] • Field: icon - cannot access file at ‘./img/logo.png’.
[exp] • Field: splash.image - cannot access file at ‘./img/splash.png’.

1 Like

What OS are you on, maybe you need to chmod the read/write permissions?

Hi, I use macOS sierra

@omorhefere try to optimize your logo / splash image size.

Last time i face this that my splash image have size around 400kb, i optimize my splash image under 100kb and that warning is disappear

1 Like

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.