Can not start Expo prohect

Please provide the following:

  1. SDK Version: 38.0.2
  2. Platforms(Android/iOS/web/all): all

I created new project using expo init and when i run expo start i get
Cannot determine which native SDK version your project uses because the module expo is not installed. Please install it with yarn add exp o and try again.
I tried npm install and i get the below
npm ERR! FetchError: request to failed, reason: connect ECONNREFUSED 127.0.0

Hello @gerrard7
Have you tried the following procedure?

  • Navigate to your main directory
  • Install Expo client globally
npm install -g expo-cli

After the installing process finishes, try navigating to your Project folder and run npm install.
After that use expo start and it should work.

Let me know if you manage to solve this way!

Hello @silvex
It is installed, old projects run normally only new projects fails

Is this the only error log you get?

Hello @silvex
It was local issue something (may be virus :smile: ) changed the hosts file on windows for https://codeload.github. to be localhost you can see this in error :smile:
I restored old hosts file and everything went fine thank for your help

1 Like

Glad you got things sorted out, @gerrard7. Thanks for lending a hand @silvex!

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.