Can I use remote debugging with 'exp start --no-dev --minify'

My app works in the simulator in my Mac, but not when I publish it with “exp publish”, so I need to debug. I found a related issue suggesting I could run…

exp start --no-dev --minify

…to debug. Initially this does not seem to support remote debugging. Correct? Can I enable remote debugging so I can use console.log?


hi @arnoldbird, regarding your app not working when published, one of the main differences is that __DEV__ is true in development but false when published. If you rely on this variable being true, it could cause problems for you.

Regarding the debugging, im not quite sure if remote debugging will work when you turn off development mode. Does the debugger-ui address work for you?

We’ve got an article about debugging here:

Thanks quinlanj. I tried the debugger-ui address, but in Chrome I am seeing…

No ‘Access-Control-Allow-Origin’ header is present on the requested resource. Origin ‘http://localhost:19001’ is therefore not allowed access. If an opaque response serves your needs, set the request’s mode to ‘no-cors’ to fetch the resource with CORS disabled.

My app doesn’t work in any kind of simulator since running ‘exp publish’ this morning. I have spent the last several hours trying to restore the functionality that existed before I ran ‘exp publish’. I created a separate issue at Does ‘exp publish’ change an app? (e.g. break it)

Everything is working well now. I think maybe all the issues I ran into today were the indirect result of nesting TouchableOpacity inside of Text.

1 Like

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.