Building standalone apps


Help needed to build standalone app.

  1. I use “create-react-native-app test1” to create an app.
  2. then “exp login”
  3. then “exp build:android”
  4. then “exp build:status”

All goes well, but it fails to build an APK.
I have tried to change the app.json, and the expo.json but nothing results in an APK.

What am I missing?


Does it throw any specific error?

Unfortunately not. It just says it failed to create the APK.
Thats why I was wondering if someone had a nice simple guid I can follow so I can see what I did wrong, and get it working.

@antprog sorry you’re having issues with the standalone build! We know this needs improvement and have a number of things planned and in progress. Can you message me on our Slack (I’m ap there) with details of your app and your username?


Ok. full details.

I made a vanilla app using: ‘create-react-native-app’
I only added 1 line of code to the app (including import)
AppRegistry.registerComponent(‘main’, () => App);

Had to remove app.json, and created a exp.json with the following code.
tried to build an APK, and it just says error.
My username is “antprog” or
app name is “showprob”

“name”: “Show problem”,
“icon”: “./icon.png”,
“version”: “1.0”,
“slug”: “antprogShowProb”,
“privacy”: “unlisted”,
“orientation”: “default”,
“primaryColor”: “#000000”,
“sdkVersion”: “17.0.0”,
“notification”: {
“icon”: “./icon48.png”,
“color”: “#000000”,
“androidMode”: “default”,
“androidCollapsedTitle”: “#{unread_notifications} new interactions”
“loading”: {
“icon”: “./icon48.png”,
“exponentIconColor”: “blue”,
“backgroundImage”: “./background.png”,
“backgroundColor”: “#000000”,
“hideExponentText”: false
“appKey”: “main”,
“androidStatusBarColor”: “#000000”,
“androidStatusBar”: {
“barStyle”: “dark-content”,
“backgroundColor”: “#000000
“entryPoint”: “./App.js”,
“extra”: {
“extradata”: “pass to app”,
“anything”: “you want”
“ios”: {
“bundleIdentifier”: “biz.antsoftware.showprob”,
“buildNumber”: “1”,
“config”: {
“branch”: {
“apiKey”: “myapiKey”
“usesNonExemptEncryption”: true,
“googleMapsApiKey”: “map-key”,
“googleSignIn”: {
“reservedClientId”: “signin-key”
“isRemoteJSEnabled”: true,
“supportsTablet”: true,
“infoPlist”: {
“key1”: “add stuff here if u wish”,
“otherstuff”: “otherval”
“associatedDomains”: [
“android”: {
“package”: “biz.antsoftware.showprob”,
“versionCode”: 1,
“config”: {
“branch”: {
“apiKey”: “myapiKey”
“fabric”: {
“apiKey”: “apikey”,
“buildSecret”: “mysecret”
“googleMaps”: {
“apiKey”: “mapkey”
“googleSignIn”: {
“apiKey”: “mapkey”,
“certificateHash”: “put hash here”
“facebookScheme”: “fbschemedigits”

Are you able to share the source of this project? You definitely don’t want to use AppRegistry yourself in a CRNA project – it’s handled for you by the entry point that’s configured in package.json.


Try the following.
Create an app.
With NO changes try and create an .apk with the config file I posted here.
It just fails, and says there was an error.

Can someone please help me out with the most basic sample.
I just want to be able to create a .apk with a hello world app.

hello! here is an example hello world project that is configured with minimal necessary app.json fields in order to build a standalone app from a CRNA project: GitHub - brentvatne/hello-world-crna-standalone – i tested this on android and it should work the same on ios.

let me know if you have any further questions!

Thank you!

Your example works perfectly!
I can now proceed and use this for production apps.

I’m very thankful!

1 Like

hurray! i’m so glad it worked for you @antprog :slight_smile:

What about the ‘scheme’ config? I have set up the app.json just like this repo, but the linking uri I get when redirecting back to my app (Standalone iOS, not detached) is

How can I make it work?


Hey dikaiosune,

I had created a app with
create-react-native-app FAeGS
cd FAeGS
npm start

My app.json

“expo”: {
“name”: “FAeGS”,
“icon”: “E:\bills\rupee-512.png”,
“version”: “1.0.0”,
“slug”: “your-app-slug”,
“sdkVersion”: “22.0.0”,

"ios": {
  "bundleIdentifier": "com.FAgES.FAgES"
  "android": {
  "package": "com.FAgES.FAgES"

Referred Doc…
I m trying to build this app using
exp build:android

It asks for password and then i enter my password it gives error

EXP-00056: ORACLE error 1017 encountered
ORA-01017: invalid username/password; logon denied

Again asks for username/password

Finaly after entering this i get error
EXP-00056: ORACLE error 12170 encountered
ORA-12170: TNS:Connect timeout occurred
EXP-00000: Export terminated unsuccessfully

yes i m able to share the source of this project…

Please help me out
expo username :- KhilwaniKaran

ORACLE error 1017 encountered

This doesn’t look like an Expo error. Looks like you’re having issues with a firewall or VPN.

Hey Jesse
I found the resolution
The problem is due to Oracle Installed on yours machine
Oracle also has an utility tool as exp
that also has command as exp

i was also having oracle installed on my machine
Here you will find an exe file as exp.exe
rename it and then try again…

Doing this solved my issue,…