Building detached app for Testflight not updating.

Hi, I am trying to deploy an updated version of my React Native app to test flight.

I am archiving the app and then deploying via Xcode to AppStoreConnect, However, the latest build is not reflective of what is running on my simulator. I am incrementing the build, version, and release numbers and I have even tried clearing my build folder. As I assumed it might be a caching issue, but none of these attempts have taken effect. All of my releases are the same as the first release I made months ago.

Any input would be greatly appreciated.

1 Like

@jsworyk Have you resolved your issue? I am having the same problem.

Have you tried publishing before doing the release? Publishing updates certain files such as:

  • android/app/src/main/assets/shell-app-manifest.json
  • android/app/src/main/assets/shell-app.bundle
  • android/app/src/main/java/host/exp/exponent/generated/
  • ios/biopointe/Supporting/EXShell.json
  • ios/biopointe/Supporting/EXShell.plist
  • ios/biopointe/Supporting/shell-app-manifest.json
  • ios/biopointe/Supporting/shell-app.bundle