build process stops

This just started happening, running build used to work fine

expo build:ios -t managed

But now at the end of the build process I get

Checking if this build already exists...

Not Found.

This issue was already posted and closed, Build stops at Checking if this build already exists..., it mentioned deleting some keystore but not sure what this is or where or what the file name is.

Expo CLI 3.27.6 environment info:
      OS: macOS 10.15.6
      Shell: 5.7.1 - /bin/zsh
      Node: 14.2.0 - /usr/local/bin/node
      Yarn: 1.13.0 - /usr/local/bin/yarn
      npm: 6.14.5 - /usr/local/bin/npm
      Watchman: 4.9.0 - /usr/local/bin/watchman
      CocoaPods: 1.8.4 - /usr/local/bin/pod
      iOS SDK:
        Platforms: iOS 13.7, DriverKit 19.0, macOS 10.15, tvOS 13.4, watchOS 6.2
      Android Studio: 4.0 AI-193.6911.18.40.6626763
      Xcode: 11.7/11E801a - /usr/bin/xcodebuild
      expo: ^38.0.10 => 38.0.10
      react: ~16.13.1 => 16.13.1
      react-dom: 16.13.1 => 16.13.1
      react-native: ~0.62.2 => 0.62.2
      react-native-web: ~0.13.12 => 0.13.12
      react-navigation: ^4.4.0 => 4.4.0
      expo-cli: 3.27.6
    Expo Workflow: managed

Not sure what happened on the expo builds site but after deleting my project, then running the build command again, the project was recreated and the build worked.

Hmmm. Glad things got unblocked but sorry you had to deal with this inconvenience. I’ll let you know if we get some clarity from our end on what may have occurred here.

For what it’s worth, I was getting this too.

I deleted the project, and then ran

expo publish

and then

expo build:ios

which still gave me the not found error.

I then deleted the project, and ran

expo build:ios

without running expo publish, which works. So the problem seems to lie with expo publish?

My problem and reason for doing this was that OTA updates weren’t working, but that’s probably a different issue entirely.

Anyway, figured the expo publish insight might help the devs a little bit

I have this issue:

Checking if this build already exists...

Not Found.

and it started because I deleted my project on the expo build site. I have followed this solutions above (deleting the project and building again) but it still give me the “Not found” error. Please help!

Thank God!

Fixed it by deleting the recent builds on expo client. I deleted 3 builds which I built on the expo client today.

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.