Build:ios -t simulator not works with the -c option

This is long waited feature for me, but unfortunately if a set both -c and -t simulator, the -c part is ignored, which makes impossible to get a successfully build. Tried a lot of combinations, same result .

(Build:ios not working without --clear-credentials option)

Should I open a github issue? Or there is something I missed?

Hi, so turns out the production machines were running an older version of the expo code and they have since been updated. Sorry for the inconvenience! Please try running exp build:ios -t simulator again. Credentials should not be required since it is a build for the simulator, so passing in the ‘c’ flag should not matter.

Once the build completes (verify this with exp build:status, you can follow the directions here to unpack your tarball and run your app in the simulator:


Didn’t realize that -c would not matter. But I tried it again and, unfortunately, didn’t work also.

All I get is [exp] iOS: There was an error with this build.

On the other hand, if I build without aiming a simulator build, it works normal, I can get a fine ipa file.
Same if I just run within the local simulator with expo.

Do you know what could it be?

Thank you for the feedback!

You will need to remove the single quote from your manifest name (ie) That’s => Thats. We will patch this up in the next release, but for now try removing the single quote and seeing if the build goes through.

1 Like