Build:ios fails with newer exp versions

Hey all,

I’m having issues building my standalone apps after upgrading exp. After some googling, I’ve found that authentication with Apple is now done locally, which is cool - but I can’t get it to work.

A week ago, I was still on exp v 49.x.x, and everything was working fine. I then upgraded to 51.0.1, and I ran into issues. After the easter break, I’ve now upgraded to 51.4.0, but it didn’t help.

When i run build:ios, the build fails with unable to get credentials, as seen here:

Some build attempts for debugging:

Between each attempt, I’ve tried logging out of exp and back in, but with no effect. At some point the cli also asked me to either login with a new or existing user, in spite of me already being logged in. I tried choosing existing and logged in with my user, but that did not help either. No passwords or anything have been changed on the Apple side of things.

Any help would be much appreciated, I need to get this app in Apple review ASAP :wink:

So I had started another build while writing the post above, and lo and behold, it went through! I changed absolutely nothing.

As such, consider my issue tentatively resolved - but it would be great to know what went wrong on the previous builds if you have any logs of that, to perhaps alleviate the problem from others who runs into the same issue.

Thanks! :slight_smile:

I am having the same issue

on the third go it went through, while reading this.
Tip: read this post while doing it. It seems to be randomly helping (lol)

1 Like

Hi jhalborg. Thanks for your post: you weren’t the only person affected by the problem, but the information you posted really helped me map it out.

In brief, our credential storage system had was in lowered availability from Sunday night to Monday afternoon, and that greatly increased an otherwise very rare kind of ios build failures, this “unable to get credentials” problem you experienced.

As you noticed, we did fix the problem, and we’re doing a lot more to make sure this can’t happen again. Sorry for the delay, and I hope you were able to submit your update.

1 Like

Hi, has this problem returned?

I have tried to build for iOS several times but always get the error:

getting credentials
unable to get credentials

Same issue here =/

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.