build:ios certificate error


I am trying to build iOS bundle and I am getting following error:

[stderr] security: SecKeychainItemImport: Unknown format in import.
unable to import distribution certificate into keychain
Error: Process exited with non-zero code: 1
    at ChildProcess.child.on (/usr/local/turtle-js/node_modules/xdl/node_modules/@expo/spawn-async/build/spawnAsync.js:39:21)
    at emitTwo (events.js:126:13)
    at ChildProcess.emit (events.js:214:7)
    at maybeClose (internal/child_process.js:915:16)
    at (internal/child_process.js:336:11)
    at emitOne (events.js:116:13)
    at Socket.emit (events.js:211:7)
    at Pipe._handle.close [as _onclose] (net.js:561:12)

I created distribution certificate myself and provided a path to it, I let expo manage the rest. I am using expo 2.11.9

Any ideas what might be wrong?

thank you

I run the build again and let expo generate the certificate this time - it worked! No idea what was wrong with original cert.

key command was:

expo build:ios -c

which will run build clean and you can change all options.


Hey @lotcz,

Glad you got this resolved. Thanks for sharing the answer with the community as well.

All the best,

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.