Build error I don't know how to debug

The app runs fine on Expo app yet whenever I want to build it results in a final error of.

Error: ENOENT: no such file or directory, lstat '/app/turtle/workingdir/android/sdk36/android-shell-app/app/build/outputs/bundle/release/app.aab'

In the middle it has bunch of "Unable to strip errors ```
due to missing strip tool for ABI ‘X86’

I've tried deleting package-lock.json and node_modules. Tried googling for the question but I don't really know what to do. The abstraction of Expo is really biting me here.

Expo CLI 3.11.1 environment info:
      OS: Linux 5.0 Ubuntu 18.04.3 LTS (Bionic Beaver)
      Shell: 4.4.20 - /bin/bash
      Node: 12.6.0 - /usr/local/bin/node
      npm: 6.13.3 - /usr/local/bin/npm
      expo: ^36.0.0 => 36.0.0 
      react: 16.9.0 => 16.9.0 
      react-native: => 0.61.4 
      react-navigation: ^3.12.0 => 3.13.0 
      expo-cli: 3.11.1


This is a problem that the Expo team is aware of.

As a temporary workaround you could build an APK instead of an App Bundle. But this should be fixed soon.

Looks like it’s been fixed now.

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.