Build error after upgrading to SDK 34

I am getting this error after upgrading from SDK 33 to 34:

Unable to resolve “./Google” from “node_modules\expo\build\ExpoLazy.js”

Work environment is down again.

Best …,

I am having the same issue after upgrading from SDK 33 to SDK 34 yesterday (August 7) following the guide in the release blog post.

1 Like

Starting with the -c flag will resolve it (clears the React Native packager’s cache).

expo start -c


1 Like

@liquify-stephen that solved it for me (or got to the next error at least)

Did it work for you too @eggnukes ?

Thanks a bunch!


Thanks for chiming in here and helping others, @liquify-stephen! :ok_hand:

1 Like

@caminoninja, what worked for me and got rid of all upgrade related errors was:

  1. Delete node_modules folder.
  2. Delete package-lock.json.
  3. Run npm install.
  4. Run expo start -c.

Make sure you have latest Expo CLI version (npm install -g expo-cli) before you do this or you might have to do it all again.

That’s what I did and it worked for me too. But had some extra problems.

That is if it was package-lock.json you deleted, right?



Yeah, package-lock.json was the right one. Thanks! :slight_smile: Edited the comment.

It would depend on whether you’re using yarn or npm to install dependencies.

For yarn it’s yarn.lock. For npm it’s package-lock.json.

1 Like

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.