Build app for iOS 15

Please provide the following:

  1. SDK Version: 42
  2. Platforms(Android/iOS/web/all): iOS
    OS expo-cli 4.12.0
    Node 12

I currently installed sentry via expo install sentry-expoalong with all recommended additional dependencies.

I have tested it on expo simulator with Sentry.Native.captureException("testing ios error"); which logs to my sentry dashboard.

However when I run eas build --profile preview --platform all I get an error which dispalys:

:x: error: API request failed

the transform cache was reset.

› Generating debug EagleEyeInspections »
› Executing EagleEyeInspections » [CP] Copy Pods Resources
› Executing EagleEyeInspections » Upload Debug Symbols to Sentry

:x: error: API request failed

▸ The following build commands failed:
▸ PhaseScriptExecution Upload\ Debug\ Symbols\ to\ Sentry /Users/expo/Library/Developer/Xcode/DerivedData/EagleEyeInspections-cgxeafiultmcacebeduxrcnyvumf/Build/Intermediates.noindex/ArchiveIntermediates/EagleEyeInspections/IntermediateBuildFilesPath/ (in target ‘EagleEyeInspections’ from project ‘EagleEyeInspections’)
▸ (1 failure)

When I run expo build:ios it works.

app.json contains:
    "plugins": ["sentry-expo"],
    "hooks": {
      "postPublish": [
          "file": "sentry-expo/upload-sourcemaps",
          "config": {
            "organization": "Codesto",
            "project": "eagleeyeapp",
            "authToken": "5238347c516711eca3335e4f87b0a460"


  "build": {
    "preview": {
      "distribution": "internal"
    "preview-enterprise": {
      "distribution": "internal",
      "ios": {
        "enterpriseProvisioning": "universal"

Any ideas what I’m doing wrong?

Fixed my mistake was I didn’t create an auth token I was using the secret key assuming that was the auth token for Sentry.

1 Like

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.