Blank Google Maps with MapView on IOS TestFlight

Hi! I use Google Maps in my application, in Expo Client it works perfectly. I have an Google Place autocomplete field too in the same page working with the same api-key, but MapView doesn’t seem to take it. The map is there, but there’s no textures, it’s only blank. I set a marker in it with a circle, both are rendered. I don’t want to eject expo until it’s my final step.

Really simple usage:

            pitch: 0,
            heading: 0,
            altitude: 0,
            zoom: 10,
          onMapReady={(e) => {
            alert('map is ready ' + Constants.manifest.ios.config.googleMapsApiKey)
          <Marker coordinate={} />
            radius={this.state.range * 1000}

This is my application. the map is there, but no textures. Just below (Company address) is a Google place autocomplete field with the same API key by I pass the key directly and it works well

I tried to alert Constants.manifest.ios.config.googleMapsApiKey but it makes my application crash (only on TestFlight) and says that it’s undefined.

Unhandled JS Exception: undefined is not an object (evaluating 'C.default.manifest.ios.config.googleMapsApiKey')

  "expo": {
    "ios": {
      "supportsTablet": true,
      "bundleIdentifier": "",
      "config": {
        "googleMapsApiKey": "*******************"

Update: I tried to alert(Constants.manifest)and there’s no googleMapsApiKey in it. When in Expo, it shows the api key.

If it is, how my api key is passed?

Thank you for your help!

I had this exact same issue. Worked fine in Expo. Build and upload to Testflight and the map outline, Google logo, and marker where all present, but the map didn’t show up. Seemed to zoom, and change lat/lng when the marker changed.

I found this article, which lead me to try enabling Maps SDK for IOS, and it instantly started working. Hope this helps!