AuthSession and remote debugging issue


If I run the iOS Simulator and select under my recently opened projects my current expo project, I can perform my oAuth2 authentication flow without any issues.

If I run the iOS simulator in debug mode (Development mode checked) and select my project under recently in development, the AuthSession.getRedirectUrl returns undefined and localhost causing my app to fail authenticating because the redirect url is incorrect.

Here is the print out of AuthSession.getRedirectUrl():

Is there a reason why the Expo debug mode causes the app to not be authenticated to Expo?

In non-debug mode, I get back a valid redirect url which I can use with my oAuth2 authentication flow.

Thank you, Bastien

1 Like

Any suggestions please! I’m still running into the UNVERIFIED issue and I’m not sure how to get to the debug mode without resolving this issue. Thank you.

I tried to delete and recreate my Expo account and that did not help resolve the issue.

I fixed my issue by choosing a different version of iOS for the simulator. For some reason the version I was working with iOS 8 would not return the redirect url values correctly. Using X, the issue went away. Please feel free to close.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.