Application stops working on android

@davidbova I’m on SDK19, so I think downgrade will do anything

1 Like

@kilhog thank you for this

1 Like

Tried on sdk21. Same

1 Like

Joining the choir on this one.

SDK 22.x.x building for Android.

My stack trace:

java.lang.NoClassDefFoundError: Failed resolution of: Lbolts/AppLinks;
	at com.facebook.appevents.internal.SourceApplicationInfo$Factory.create(
	at com.facebook.appevents.internal.ActivityLifecycleTracker.onActivityCreated(
	at com.facebook.appevents.internal.ActivityLifecycleTracker$1.onActivityCreated(
	at host.exp.exponent.experience.d.onCreate(
	at host.exp.exponent.experience.a.onCreate(
	at host.exp.exponent.experience.ExperienceActivity.onCreate(
	at host.exp.exponent.experience.ShellAppActivity.onCreate(
	at android.os.Handler.dispatchMessage(
	at android.os.Looper.loop(
	at java.lang.reflect.Method.invoke(Native Method)
Caused by: java.lang.ClassNotFoundException: Didn't find class "bolts.AppLinks" on path: DexPathList[[zip file "/data/app/dk.XYZ/base.apk"],nativeLibraryDirectories=[/data/app/dk.XYZ/lib/x86, /data/app/dk.XYZ/base.apk!/lib/x86, /vendor/lib, /system/lib]]
	at dalvik.system.BaseDexClassLoader.findClass(
	at java.lang.ClassLoader.loadClass(
	at java.lang.ClassLoader.loadClass(
	... 23 more
	Suppressed: java.lang.ClassNotFoundException: bolts.AppLinks
		at java.lang.Class.classForName(Native Method)
		at java.lang.BootClassLoader.findClass(
		at java.lang.BootClassLoader.loadClass(
		at java.lang.ClassLoader.loadClass(
		... 24 more
	Caused by: java.lang.NoClassDefFoundError: Class not found using the boot class loader; no stack trace available
1 Like

I have same problem and there are others reporting about this problem in expo developers slack channel.

1 Like

Same issue, glad it’s not just me

1 Like

Hey everyone, this should be fixed now. You’ll have to re-run exp build to get a new APK. Let me know if it still fails for you after trying again.


Thank you @jesse ! :clap:

I have a weird problem now.
I build the .apk with exp build:android, transfer the file to my phone and installs. The application works perfectly.

But, if I publish through Google Play (same .apk), and download and installs via Google Play, the application crashes on load. Before the application crashes, it does load up and I see the first screen and the application asks for permission to access the camera (this is expected), however, before I can press ‘accept’, the application crashes.

It works now! Thanks! @jesse

Thanks @jesse. It works now.

I can confirm that it works now after upgrading of exp cli to 45.1.0

mine is still failing , same error but i have detached my project from expo

sorted for me - thank you again @jesse

My build is failing as well. Can’t run exp build because my project is detached.

[exp] exp build is not supported for detached projects.

I can confirm that it works after adding the following to build.gradle to a detached build.

dependencies {
    compile 'com.parse.bolts:bolts-android:1.1.3'

I added this snippet posted by @rintoj

dependencies {
    compile 'com.parse.bolts:bolts-android:1.1.3'

This allows our app to be assembled in debug mode, but now our release build fails with this error:

> Building 95%
> :app:transformClassesWithJarMergingForMainRelease:app:transformClassesWithJarMergingForMainRelease FAILED
> Building 95%
FAILURE: Build failed with an exception.

* What went wrong:
Execution failed for task ':app:transformClassesWithJarMergingForMainRelease'.
> duplicate entry: bolts/AggregateException.class

@jesse You mentioned “this should be fixed” – would you mind sharing the root cause of the issue?

You need to remove the exclude module block from compile ''

1 Like


$ create-react-native-app sample
$ cd sample
$ yarn run eject
$ cd android
$ ./gradlew assembleDebug

and Deploy -> bolts.AppLinks Error!!
When will it be fixed?

Hi I had same problem and seems to fix it after applying your example.
But now I am facing another error message.


Do you have any idea?

this kind of error is really frustrating.