AppleAuthentication impossible to localize the button

Hi, i can not localize the button of AppleAuthentication. The doc specify to add "CFBundleAllowMixedLocalizations": true to ios.infoPlist property in the app.json but nothing seem to change.
There are something else to do ? I try to install expo-localization but no change. Maybe this feature only works in standalone ?

Please provide the following:

  1. SDK Version: 38
  2. Platforms(Android/iOS/web/all): iOS
  3. expo-apple-authentication Version: 2.2.1

Ok this is work only in standalone app. It would be a good idea to add it in the doc to avoid unpleasant surprises. :slightly_smiling_face:

I also added "CFBundleDevelopmentRegion": "fr" in ios.infoPlist but i don’t know if it’s necessary.

But now i have a secondary problem, in standalone app the button doesn’t work. Nothing happens when I press it… :frowning_face:

Hey @nangot,

Sorry for not getting a response to you on your initial post. Thanks for sharing an update and we will definitely take note of this and find a place to add to our documentation so that others can avoid the confusion you experience.

As for the new problem, had the button worked before or is this your first time trying in the standalone environment? Also, can you double check to make sure you’ve properly made all the necessary configuration to enable Apple Auth. Lastly, are you testing on a real device or a simulator? It’s best to test on a real device when possible:


Hi @adamjnav,

It works perfectly with expo and it never worked in standalone. I test on a real device with TestFlight. Thanks for your suggestion, I also believe it’s a configuration problem on the Apple side. I look at this ! :wink:

1 Like

Well, that was a configuration problem on the Apple side! I am not alone on this project and the “Key” was not set correctly. :frowning:

Thanks, problem solved!

Glad to hear things have gotten resolved! Best of luck with your project moving forward.

Hello @nangot,

Can I ask you how did you fix the configuration on the Apple side? I’m meeting the same problem as you (nothing happens when I touch the Sign In button), and I followed the configuration steps on the expo-apple-authentication documentation.
I’m new with Apple Developer, I’ll try to describe what I have:

  • I have an Apple Id (my only identifier) whose capabilities are Push Notifications and Sign In with Apple (enabled as a primary App ID)
  • Two keys:
    – one with one service: Apple Push Notifications service (created first, before I started developing on this project)
    – another one with one service: Sign in with Apple (that I created)
  • A domain and an email address for users who use Apple’s private email relay service

For the first key, should I enable the service Sign in with Apple and delete the second key?

I don’t have any iOS device, I can only work with emulators so it’s complicated for me to see if the Sign In with Apple button works as it’s working fine on my emulator.

Thank your for your answers,


Hello @lolalp,

I already had a key for Push Notification but not currently used. So to be sure i deleted this key and created a new one with Apple Push Notification and Sign in with Apple services enabled. But just enable Sign in with Apple in the first key should be work i suppose.
To be sure add the “–clear-provisioning-profile” option when make a build for the new provisioning profile include the new key.
I don’t know if the provisioning profile can be generate with two key, my tests were inconclusive.

I have not tested on emulator, I don’t know if it’s supposed to work well.

Good luck!

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.